O seu servidor funciona com a versão 5.1.6 do PHP, mas o WordPress 4.1.24 necessita pelo menos da versão 5.2.4.